华为网络设备命令大全

本文阅读 4 分钟
首页 技术控 正文

配置交换机的名称和密文密码:

//用户视图
system-view //进入系统视图配置
[Huawei] //系统视图
[Huawei]quit 或 return //退出系统视图模式
[Huawei]sysname DTWLXY //设置主机名
[Huawei]user-interface console 0 //进入控制台
[Huawei-ui-console0]authentication-mode password
[Huawei-ui-console0]set authentication password cipher huawei //配置密文密码

配置交换机的远程管理 IP 地址:

[Huawei]interface Vlanif 1 //进入 VLAN1
[Huawei-Vlanif1]ip add 192.168.1.254 24 //配置 IP
[Huawei-Vlanif1]undo shutdown //开启接口
[Huawei]dns domain dtwlxy.com //设置域名
[Huawei]dns server 192.168.254.254 //设置域名 IP
dis vlan 显示 vlan save 保存配置
dis curr 显示当前配置 reboot 重启设备
undo terminal monitor //取消提示信息

配置交换机端口速率、双工、ARP:

[Huawei]int g0/0/1 //进入接口
[Huawei-g0/0/1]description dtwlxy //端口描述
[Huawei-g0/0/1]undo negotiation auto //取消协商
[Huawei-GigabitEthernet0/0/1]duplex full //全双工
[Huawei-GigabitEthernet0/0/1]auto duplex full //自动
l [Huawei-GigabitEthernet0/0/1]speed 10 //速率 10M
[Huawei-GigabitEthernet0/0/1]auto speed 100 //自动
[Huawei]arp static 192.168.1.8 5489-98cf-2603//绑定
[Huawei]dis arp [Huawei]dis arp all //查看 ARP11

配置路由器接口 IP:

l [Huawei]int g0/0/1 //进入接口
[Huawei-g0/0/1]ip add 192.168.1.6 24 //配 IP 地址
[Huawei-GigabitEthernet0/0/1]undo shutdown //开启
dis cur 或 [Huawei]dis cur //查看 ARP

配置静态路由

[Huawei]ip route-static 192.168.20.0 24 10.0.12.2
[Huawei]ip route-static 192.168.10.0 24 serial 0/0/1
[Huawei]ip route-static 0.0.0.0 0 192.168.1.5 //默认
[Huawei]dispaly ip routing-table //查看路由表

配置交换机 VLAN 相关命令:

[Huawei]vlan 10 或 [Huawei]vlan 20 //创建 VLAN
[Huawei-vlan10]description dtwlxy //VLAN 描述
[Huawei]vlan batch 30 40 //创建多个 VLAN
[Huawei]int g0/0/1 //进入接口
[Huawei-g0/0/1]port link-type access //访问口
[Huawei-g0/0/1]port default vlan 10 //加入 VLAN
[Huawei-g0/0/2]port link-type trunk //干道口
[Huawei-g0/0/2]port trunk allow-pass vlan 10 20 允许
[Huawei-g0/0/2]port trunk allow-pass vlan all //所有
[Huawei]int e0/0/2 //进入接口
[Huawei-E0/0/2]port link-type hybrid //混合口模式
[Huawei-E0/0/2]undo port default vlan //删除默认 vlan
[Huawei-E0/0/2]port hybrid untagged vlan 20//去标签
[Huawei-E0/0/2]port hybrid pvid vlan 2//设置默认 vlan
[Huawei-E0/0/2]port trunk allow-pass vlan 10 to 100
[Huawei]dis port vlan //查看 vlan
[Huawei]display vlan //查看 vlan

配置交换机 VLAN 一致性 GVRP:

Normal 模式: (类似 cisco 交换机服务器模式)
[Huawei]gvrp //开启 gvrp 也是默认模式
Fixed 模式: (类似 cisco 交换机客户机模式)
[Huawei-g0/0/2]gvrp registration fixed
Forbidden 模式: (类似 cisco 交换机透明模式)
[Huawei-g0/0/3]gvrp registration forbidden
dis vlan summary //查看 vlan 汇总
dis gvrp status //查看 gvrp 状态 1

配置路由器 RIP 协议:RIPv1 RIPv2

[Huawei]rip //启用 RIP 默认 v1
[Huawei-rip-1]network 192.168.1.0 //发布直连网段
[Huawei-rip-1]version 2 //配置 v2 版本
[Huawei]dis rip //查看 rip
[Huawei]dis rip database //查看 rip 数据库
[Huawei]dis ip routing-table //查看路由表
优先级:直连 0、静态 60、rip 100、ospf 10/150

配置路由器 OSPF 协议:

[Huawei]ospf 1 //启用 OSPF 默认是进程 1
[Huawei-ospf-1]area 0 //进入区域 0
[Huawei-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255 //发布直连网段
[Huawei-ospf-1]silent-interface g0/0/2 //被动接口
[Huawei]dis ospf interface //查看 ospf 通告
[Huawei]dis ospf peer //查看 ospf 邻居
[Huawei]dis ip routing-table //查看路由表
[Huawei]dis ospf routing //查看 ospf 路由表

配置基于全局的 DHCP 协议:

[Huawei]dhcp enable //开启 dhcp
[Huawei]ip pool dtwlxy //地址池名
[Huawei-ip-pool-dtwlxy]network 192.168.1.0 //地址池
[Huawei-ip-pool-dtwlxy]lease day 2 //租约默认 1
[Huawei-ip-pool-dtwlxy]gateway-list 192.168.1.254 //网关
[Huawei-ip-pool-dtwlxy]excluded-ip-address 192.168.1.250 192.168.1.253 //排除 IP 范围
[Huawei-ip-pool-dtwlxy]dns-list 8.8.8.8 //DNS 服务器
[Huawei-G0/0/0]dhcp select global //基于全局

配置基于接口的 DHCP 协议:

[Huawei]dhcp enable //开启 dhcp
[Huawei]int g0/0/1 //进入接口
[Huawei-G0/0/1]dhcp select interface //基于接口
[Huawei-G0/0/1]dhcp server lease day 2 //租约默认 1
[Huawei-G0/0/1]dhcp server excluded-ip-address
192.168.1.1 192.168.1.10 //排除 IP 范围
[Huawei-G0/0/1]dhcp server dns-list 8.8.8.8 //DNS
[Huawei]dis ip pool //查看 dhcp
客户机:自动获取, 查看 ipconfig、ifconfig

配置路由器基本 ACL:2000-2999

l [Huawei]acl 2000 //配置基本 acl
[Huawei-acl-basic-2000]rule 5 permit source 1.1.1.1 0 //允许源 IP(注意反掩码 0,默认步长 5)
[Huawei-acl-basic-2000]rule 10 deny any //拒绝任意
l [Huawei]user-interface vty 0 4 //进入接口
[Huawei-ui-vty0-4]acl 2000 inbound //应用 acl
l [Huawei]dis acl all //查看所有 acl
[Huawei]dis acl 2000 //查看 acl 2000

配置路由器高级 ACL:3000-3999

[Huawei]acl 3000 //配置高级 acl
[Huawei-acl-adv-3000]rule permit ip source 1.1.1.1 0 destination 4.4.4.4 0 //允许访问
[Huawei]user-interface vty 0 4 //进入虚拟接口
[Huawei-ui-vty0-4]acl 3000 outbound //应用 acl
[Huawei]int g0/0/1 //进入接口
[Huawei-G0/0/1]traffic-filter inbound acl 3000 //应用
[Huawei]dis acl all //查看所有 acl

静态 NAT 配置:

system-view
[huawei]interface Ethernet 0/0/1
//进入端口视图
[huawei-Ethernet0/0/1]ip address 192.1.1.1 30 //设置端口 IP 地址,网络号 30 位
[huawei-Ethernet0/0/1]nat static global 192.1.1.2 inside 10.1.1.2
//静态 NAT 映射,私有地址 10.1.1.2
和公有地址 192.1.1.2 建立映射关系

动态 NAT 配置:

[huawei]nat address-group 1 192.1.1.2 192.1.1.4
//定义公有地址池
[huawei]acl 2000
[huawei-acl-basic-2000]rule permit source 10.1.1.0 0.0.0.255
[huawei-acl-basic-2000]quit
[huawei]interface Ethernet 0/0/1
[huawei-Ethernet0/0/1]nat outbound 2000 address-group 1 //实现 ACL2000 中定义的 IP 可以与地址池中
的地址进行 NAT 转换,这里默认配置的是 NAPT,是多对一的关系,要配置 Basic NAT,则需要加选项
no-pat

配置三层交换机 VLAN 间路由:

首先基本配置,IP、VLAN 等。

[Huawei]int vlanif 10 //进入接口
[Huawei-Vlanif10]ip add 192.168.1.254 24 //配 IP
[Huawei]int vlanif 20 //进入接口
[Huawei-Vlanif20]ip add 192.168.2.254 24 //配 IP
[Huawei]dis ip interface brief //接口简略信息
[Huawei]dis port vlan //接口 vlan 信息
[Huawei]dis vlan //查看 vlan 信息

配置单臂路由 VLAN 间通信:

首先基本配置,IP、VLAN 等。

[Huawei-G0/0/1.1]ip add 192.168.1.254 24 //配置 IP
[Huawei-G0/0/1.1]dot1q termination vid 10 //封装
[Huawei-G0/0/1.1]arp broadcast enable //开启 arp
[Huawei]dis ip interface brief //查看接口
[Huawei]dis ip routing-table //查看路由表
[Huawei]display current-configuration //查看配置

解压密码: detechn或detechn.com

免责声明

本站所有资源出自互联网收集整理,本站不参与制作,如果侵犯了您的合法权益,请联系本站我们会及时删除。

本站发布资源来源于互联网,可能存在水印或者引流等信息,请用户自行鉴别,做一个有主见和判断力的用户。

本站资源仅供研究、学习交流之用,若使用商业用途,请购买正版授权,否则产生的一切后果将由下载用户自行承担。

解决 Windows 桌面图标变白
« 上一篇 11-30
思科网络设备命令大全
下一篇 » 11-30

发表评论

惪特博客
  • 文章总数:
    18336 篇
  • 评论总数:
    52450 条
  • 标签总数:
    8615 个
  • 总浏览量:
    16090528 次
  • 最后更新:
    昨天 09:37

最多点赞

随便看看

标签TAG